Chào mừng bạn đến với Diễn Đàn Máy Chủ - Chia sẽ kiến thức máy chủ.
  • Đăng ký
    • Login:
    Server Dell email 247 Tên miền Hosting giá sốc Tang loa Frei Tang loa Frei Tên miền tiếng việt giá bèo cdn rẻ vô địch May Chu Khong Lo - Gia Xi Trum SSL 2 nam giam 15%
    + Trả lời bài viết
    Hiện kết quả từ 1 tới 3 của 3
    1. #1
      Advisors
      Tham gia ngày
      Aug 2009
      Đến từ
      xa lắm
      Bài gửi
      209

      Mặc định Huong dan cai dat va nang cap PHP 5.3.x CentOS/RedHat

      Installing or Upgrading PHP 5.3.2

      1) SSH into your box as root

      2) Ensure your in your /root directory.

      Mã:
      cd /root
      3) Lets add the Webtatic repo to YUM

      Mã:
      rpm -ivh http://repo.webtatic.com/yum/centos/5/`uname  -i`/webtatic-release-5-0.noarch.rpm
      4) We have two options here:
      Install:

      Mã:
      yum --enablerepo=webtatic install php
      or Update:


      Mã:
      yum --enablerepo=webtatic update php
      (If this does not work please try to disable regular repo's by adding the --disablerepo=* flag before the --enablerepo=webtatic flag)


      Installing or Upgrading Ioncube 5.3

      1) Go to http://www.ioncube.com/loaders.php and download the latest version for your OS. (I prefer zip format)
      Right Click the URL, Copy, and paste like so:

      Mã:
      wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.zip

      (The example url is the latest 64 bit version, at the time of this post)

      2) Untar the file or unzip it:
      Untar:

      Mã:
      tar xvfz ioncubeX.X.tar.gz
      or Unzip:


      Mã:
      unzip  ioncubeX.X.tar.gz
      3) Go into the ioncube directory you just unpacked:


      Mã:
      cd ioncube
      4) Move the ioncube php extension to the php extensions directory.

      Mã:
      cp ioncube_loader_lin_5.3.so /usr/lib64/php/modules/ioncube_loader_lin_5.1.so

      (This is the correct directory on most 64 bit systems. If this is incorrect run 'ls -lai /usr' and check to see where it is.)

      5) Now you need to create a new file and insert the following code into it:
      Create/open the file:

      Mã:
      nano /etc/php.d/ioncube.ini
      Insert this code:

      Mã:
      ; Enable ioncube extension module
      zend_extension =  /usr/lib64/php/modules/ioncube_loader_lin_5.1.so
      That's it!

      Restart or Gracefully Restart Apache

    2. #2
      Thành Viên Mới
      Tham gia ngày
      Feb 2013
      Bài gửi
      1

      Mặc định

      Quote Nguyên văn bởi canvu Xem bài viết
      Installing or Upgrading PHP 5.3.2

      1) SSH into your box as root

      2) Ensure your in your /root directory.

      Mã:
      cd /root
      3) Lets add the Webtatic repo to YUM

      Mã:
      rpm -ivh http://repo.webtatic.com/yum/centos/5/`uname  -i`/webtatic-release-5-0.noarch.rpm
      4) We have two options here:
      Install:

      Mã:
      yum --enablerepo=webtatic install php
      or Update:


      Mã:
      yum --enablerepo=webtatic update php
      (If this does not work please try to disable regular repo's by adding the --disablerepo=* flag before the --enablerepo=webtatic flag)


      Installing or Upgrading Ioncube 5.3

      1) Go to http://www.ioncube.com/loaders.php and download the latest version for your OS. (I prefer zip format)
      Right Click the URL, Copy, and paste like so:

      Mã:
      wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.zip

      (The example url is the latest 64 bit version, at the time of this post)

      2) Untar the file or unzip it:
      Untar:

      Mã:
      tar xvfz ioncubeX.X.tar.gz
      or Unzip:


      Mã:
      unzip  ioncubeX.X.tar.gz
      3) Go into the ioncube directory you just unpacked:


      Mã:
      cd ioncube
      4) Move the ioncube php extension to the php extensions directory.

      Mã:
      cp ioncube_loader_lin_5.3.so /usr/lib64/php/modules/ioncube_loader_lin_5.1.so

      (This is the correct directory on most 64 bit systems. If this is incorrect run 'ls -lai /usr' and check to see where it is.)

      5) Now you need to create a new file and insert the following code into it:
      Create/open the file:

      Mã:
      nano /etc/php.d/ioncube.ini
      Insert this code:

      Mã:
      ; Enable ioncube extension module
      zend_extension =  /usr/lib64/php/modules/ioncube_loader_lin_5.1.so
      That's it!

      Restart or Gracefully Restart Apache
      Cái này khó nhỉ. mình thử xem nào

    3. #3
      Thành Viên Mới
      Tham gia ngày
      Feb 2013
      Đến từ
      Daklak
      Bài gửi
      23

      Mặc định

      Mình có 1 số tài liệu chi tiết hơn bằng tiếng việt. Nhưng k biết bạn muốn nâng cấp php 5.3.x lên đối với CentOS version nào... 5.x, 6.x ... !? Nếu có mình sẻ sớm share lên cho bạn!

     

     
    + Trả lời bài viết

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Tags for this Thread

    Quyền viết bài

    • Bạn không thể gửi chủ đề mới
    • Bạn không thể gửi trả lời
    • Bạn không thể gửi file đính kèm
    • Bạn không thể sửa bài viết của mình